Jump to content

End Turn Error


Recommended Posts



So I took the Ernnie Island with no problems

Then I go off to t ake the North port, trying to get the mine that is up near there

This is when the problems began.
It all started out just fine, I managed to take out most of the defending force.  And then there were just too left.

They were both clearly visible I had moved my Merc's into position, so that next turn I would be able to slot them all.

So I hit my end of turn.  And nothing happens............. the turn just hangs, the enemy Macs are just standing there rocking backwards and forwards like they're ready to move but they don't do anything.  And I can wait and wait and wait and nothing happens.

I tried to load some previous saves.  Everything worked perfectly again until I only had 2 bad guys left and then exactly the same thing happened.  I tried this 3 or 4 times but with no avail.

I managed to bum rush these 2 guys and kill them.  And this ended the combat.  But it was like literally charging them down, not the one wanted to do it and I ended up getting my guys injured in the process which is not what I could have done if I hadn't been able to do it by ambushing them the way I'd planned.


A separate bug seems to have appeared in which the diamond stash that is normally available at this port was not able to be picked up.  It's marking it on the map as being available but none of my characters can go over and get it.

After many many attempts and mentioning it on steam discussions with no help I just ignored it and moved on


So I then went to the mine

this is where the slave master Graaf I think he is called is hanging out.

I managed to ambush a couple of his guys and kill them.

And then he and another goon ran out of their hut into the middle of my troops.  Wherry promptly got shot to pieces so that he surrendered.

This was the next bug.  Because now the little pseudo-messaging Skype button on the lower left hand side is now continually popping up every 2 or 3 seconds.  With his little comment of I surrender I'll help you now.................

but again if you and the turn it's in a perpetual hung mode.  With just this pseudo-Skype message popping up constantly, and there is no option to get rid of it.  If you turn it off it just pops up again and the turn never ends.

There's no option to actually talk to the guy just what I'm supposing is meant to happen.  But you can't hover over him, because as soon as you do the little window with the message I surrender and it pops up and stops you interacting with anything else.

I don't even know if I meant to wait until the end of defeating all the enemies there to talk to him.

All I know is for 2 sectors in a row

I get this end of turn bug where it just won't end the turn


Does anyone have any suggestions on what I might do to get around this bug

it's kind of annoying in fact it's almost game breaking. I don't say this very often I been playing games for something like 35 years.  And I been playing jagged alliance since I first found jagged alliance one all those years ago. (Oh my god when a 386 computer was the state-of-the-art)


Any help appreciated any suggestions appreciated

thanks very much

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...